Home > Sharepoint 2010 > Sharepoint 2010 Error Upload Profile Picture

Sharepoint 2010 Error Upload Profile Picture

the size of the small thumbnail picture function InitializeUserProfilePhotosType { $a = [System.Reflection.Assembly]::LoadWithPartialName("Microsoft.Office.Server.UserProfiles") $userPofilePhotosType = $a.GetType("Microsoft.Office.Server.UserProfiles.UserProfilePhotos") #outputs: $userPofilePhotosType.GetMethod("CreateThumbnail", [System.Reflection.BindingFlags]([System.Reflection.BindingFlags]::Static -bor [System.Reflection.BindingFlags]::NonPublic)) $userPofilePhotosType.InvokeMember("LargeThumbnailSize", [System.Reflection.BindingFlags]([System.Reflection.BindingFlags]::Public -bor [System.Reflection.BindingFlags]::Static -bor [System.Reflection.BindingFlags]::GetProperty ), $null, $null, @() For more information about configuring My Site, please refer to the following articles: http://sharepointgeorge.com/2010/configuring-my-site-sharepoint-2010/ http://technet.microsoft.com/en-us/library/ee624362.aspx Thanks, Rock WangRegards, Rock Wang Microsoft Online Community Support Thursday, February 17, 2011 If not, please create a new site for My Sites, then upload a picture into your profile. There was an updated August 2011 CU (original release .5002, updated to .5005) that was released during the month of October. weblink

All known issues with User Profile pictures have been resolved in December 2011 Cumulative update. I will test out the Dec 11 CU when it comes out and let you all know if it fixes it! Please try again later. " SharePoint > SharePoint 2010 - Setup, Upgrade, Administration and Operations Question 0 Sign in to vote Using Sharepoint 2010. Get 1:1 Help Now Advertise Here Enjoyed your answer? https://social.technet.microsoft.com/Forums/en-US/5ce9b4ec-1bd4-44b6-ae3c-823aa30caa93/cannot-update-profile-picture-trying-to-add-a-picture-to-profiles-and-i-recieve-the-follwoing?forum=sharepointadminprevious

Phillip Lyle September 7, 2011 at 10:53 am Reply I have confirmed that this is NOT fixed in the August 2011 cumulative, and will opening a ticket in hopes of getting Sherman Woo September 27, 2011 at 2:52 pm Reply My understanding is that this was introduced in SP1 and is "by-design". This blog gives you an idea of what piece of code is causing the issue: http://ianankers.wordpress.com/2011/07/15/there-was-an-error-saving-the-picture-please-try-again-later/ This is the email from MSFT: Hello Richard , The following solution has been provided

Login. at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource) at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add) at System.Collections.Generic.Dictionary`2.Add(TKey key, TValue value) at Microsoft.Office.Server.SocialData.SocialItemUrlNormalizer.BuildQuery(Uri uri) at Microsoft.Office.Server.SocialData.SocialItemUrlNormalizer.GetNormalizedPageUrl(Uri sourceUri, HttpContext context) at Microsoft.SharePoint.Portal.WebControls.SocialCommentControl.OnPreRender(EventArgs e) at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at Cheers, Rich Saturday, November 19, 2011 1:45 PM Reply | Quote 0 Sign in to vote Richard, Have you tried the Dec 11 CU? Anonymous November 3, 2011 at 10:36 am Reply Has anyone who opened a case with Microsoft for this gotten a fix?

Covered by US Patent. If you’ve create My Sites, please double check if you can access My Sites host. Anonymous November 3, 2011 at 3:15 pm Reply Was told today by MS that it is scheduled to be fixed in the December CU. -Phil Anonymous March 19, 2012 at 7:27 click here now Did I participate in the recent DDOS attacks?

If you choose to participate, the online survey will be presented to you when you leave the Technet Web site.Would you like to participate? except for the main picture on the user profile. From some of the research I found online (http://social.technet.microsoft.com/Forums/en-US/sharepoint2010setup/thread/5ce9b4ec-1bd4-44b6-ae3c-823aa30caa93/), looks like this is supposed to be resolved by the December 2011 CU, installing now, I'll post a follow up if it Apparently, it was to address some legal/privacy issues. (Don't quote me on that, but I believe it was something to this extent, and is therefore not considered a bug.) Okeo September

As an example: An administrator cannot upload a user’s profile picture to Central Administration in SharePoint Server 2010. navigate to these guys Please install this update from here: http://technet.microsoft.com/en-us/sharepoint/ff800847 More info about all changes: http://support.microsoft.com/kb/2597014 0 LVL 2 Overall: Level 2 Message Author Comment by:CanalIns2012-01-26 I thought the picture issue only surfaced But unfortunately your functions returns the german values 😉 Reply ikarstein says: May 12, 2011 at 21:29 Hi Daniel! First Name Please enter a first name Last Name Please enter a last name Email We will never share this with anyone.

I am going to wait another couple of weeks before applying to our production servers. have a peek at these guys I need to bulk update user profile photos. Are you saying that multiple user profile tool works where uploading through CA is now broken? I have had a few issues where… MS Server Apps How to Request Attention Video by: Kline Need more eyes on your posted question?

Microsoft Customer Support Microsoft Community Forums | Search MSDN Search all blogs Search this blog Sign in Microsoft Reduce Customer Effort Center Microsoft Reduce Customer Effort Center Our team drives product or is there a way to recreate the mysite for them and then update their profile picture?ReplyDeleteAnonymous25 October 2011 at 10:18Hello, the script does not work on my SP Server.i do Generated Thu, 27 Oct 2016 15:20:24 GMT by s_wx1199 (squid/3.5.20) ERROR The requested URL could not be retrieved The following error was encountered while trying to retrieve the URL: http://0.0.0.10/ Connection http://internetmairie.com/sharepoint-2010/sharepoint-2010-ie-11-compatibility.html Recent Posts SharePoint 2013: Error in “Products Configuration Wizard” after Update to SP1 Troubleshooting: Cannot access Managed Metadata Service Application in SharePoint 2013 Get Rid of Orphaned Content Types in SharePoint

Any idea's how to name my image files giving this underscore issue. blog SharePointRyan.com SharePoint Automation - Custom PowerShell Cmdlets Effective Windows PowerShell - Free eBook Mastering PowerShell - Free eBook Microsoft TechNet Script Repository - SharePoint Loading... Kind regards Ingo Reply Pingback: Sharepoint 2010 Mass Uploading profile pictures programatically «sreesp sreesp Leave a Reply Cancel reply Subscribe in a reader Subscribe by Email Follow @IngoKarstein Subscribe to Blog

I just installed SP1 and the June cumulative update and now I'm having the same problem.

Can you share the URL appears when this error is thrown? :) Saturday, October 01, 2011 12:51 AM Reply | Quote 0 Sign in to vote same i can't update the user profile image until the user first visits mysites and mysites is created for them. It is appearing to me something from the upgrade is out of sync and needs to be reset. Join them; it only takes a minute: Sign up Here's how it works: Anybody can ask a question Anybody can answer The best answers are voted up and rise to the

The login failed. Would it be ok to eat rice using a spoon in front of Westerners? I have not personally tried it. this content Wednesday, October 19, 2011 10:33 PM Reply | Quote 0 Sign in to vote - Start “Central Administration” page - Log in as site administrator - Goto “Manage User Profiles” -

Next, make sure you enable self-service site creation feature on My Site web application. Execution Time=1.98768279208670328c987-c8ff-46ea-b6da-1a44cb0cda74 02/11/2011 14:12:13.84w3wp.exe (0x2240)0x1B08SharePoint FoundationMonitoringnassVerbose____SPRequest Objects=00328c987-c8ff-46ea-b6da-1a44cb0cda74 02/11/2011 14:12:13.84w3wp.exe (0x2240)0x1B08SharePoint FoundationMonitoringnassVerbose____SQL Query Count=00328c987-c8ff-46ea-b6da-1a44cb0cda74 02/11/2011 14:12:13.84w3wp.exe (0x2240)0x1B08SharePoint FoundationMonitoringnassVerbose____Execution Time=1.98768279208670328c987-c8ff-46ea-b6da-1a44cb0cda74 02/11/2011 14:12:13.84w3wp.exe (0x2240)0x1B08SharePoint FoundationMonitoringnassVerbose____Current User=0328c987-c8ff-46ea-b6da-1a44cb0cda74 02/11/2011 14:12:13.84w3wp.exe (0x2240)0x1B08SharePoint FoundationMonitoringnassVerbose____WebPart Events Offsets=00328c987-c8ff-46ea-b6da-1a44cb0cda74 02/11/2011 14:12:13.84w3wp.exe http://get-spscripts.com/2010/12/upload-multiple-user-profile.html http://spc3.codeplex.com/wikipage?title=ProfileImageUpload I’ve also tried adjusting permission on the service application as stated in this article, http://blogs.technet.com/b/speschka/archive/2010/02/22/no-user-profile-application-available-mystery-in-sharepoint-2010.aspx. All rights reserved.

The code change occurred in Microsoft.SharePoint.Portal.WebControls.ProfileImagePicker function, within the SaveFileToPersonalSite(HttpPostedFile file) method. Even if I go to central admin > manage service applications > user profile service application > Manage user profiles I get the same results when trying to upload a picture.Luis This script is even better.ReplyDeletePhil Childs23 March 2011 at 23:10Thanks for the comments - Glad the script helped :-)ReplyDeleteAnonymous21 April 2011 at 11:54I get the following error:PS C:\Users\spsadmin> Upload-PhotosToSP -LocalPath "C:\Install\Photos" The system returned: (22) Invalid argument The remote host or network may be down.

Email check failed, please try again Sorry, your blog cannot share posts by email. %d bloggers like this: Wednesday, 1 December 2010 Upload multiple user profile pictures/photos to SharePoint using PowerShell It is now a very valuable part of creating our employee experience. SSH makes all typed passwords visible when command is provided as an argument to the SSH command ¿Cómo se destaca una palabra de un texto que ya está en cursiva? Check the spelling ofr if a path was included, verify that the path is correct and try again.At line:1 char:18+ Upload-PhotosToSP <<<< -LocalPath "D:\UserProfilePictures-Active" -MySiteUrl "http://ch-web-sps-d01:23171/sites/mysite/" -Overwrite + CategoryInfo : ObjectNotFound:

Phil Trevor Seward October 28, 2011 at 3:36 pm Reply The October 2011 CU is not quite out yet for SharePoint 2010. Everyone has rights to update profiles. What is way to eat rice with hands in front of westerners such that it doesn't appear to be yucky?